Call us on : 1-305-260-6455
Placeholder

Customer Forum

Web 2 Lead Marketing Campaign ID Cannot be Set to 0 - Solved

Dan Posted: 2017-08-24 09:57

Web 2 Lead form wasn't working. Kept getting the user redirected to the 'failure' URL.

On the 'failure' page, a message in the browser address bar said that the 'marketing campaign ID cannot be set to 0'.

Checking the HTML we had specified the marketing campaign id as follows:

(We got this information was found by clicking the 'Tracking URL' button on the 'Main' tab of the Campaign the form was related to. In there the Campaign is called 'CAMP-3'.)

SOLUTION:

Use only the numerical value from that, in this case '3'.

We edited the HTML for our Web To Lead page accordingly, re-uploaded, and tested. This time the user was redirected to the 'success' URL and the new lead had been correctly logged in the leads table.

Voila.

Dan Posted: Thu, 24.08.2017 - 09:59

(Example HTML stripped out by forum, reposting here.)

Web 2 Lead form wasn't working. Kept getting the user redirected to the 'failure' URL.

On the 'failure' page, a message in the browser address bar said that the 'marketing campaign ID cannot be set to 0'.

Checking the HTML we had specified the marketing campaign id as follows:

input name="marketing_campaign_id" type="hidden" value="CAMP-3"

(We got this information was found by clicking the 'Tracking URL' button on the 'Main' tab of the Campaign the form was related to. In there the Campaign is called 'CAMP-3'.)

SOLUTION:

Use only the numerical value from that, in this case '3'.

input name="marketing_campaign_id" type="hidden" value="3"

We edited the HTML for our Web To Lead page accordingly, re-uploaded, and tested. This time the user was redirected to the 'success' URL and the new lead had been correctly logged in the leads table.

Voila.